Signatures delay
Incident Report for Yousign
Resolved
All pending signatures were processed.
Yousign signature processing is back to normal.

Sorry for the inconvenience.
Posted Jan 07, 2022 - 13:00 CET
Monitoring
A fix has been implemented and signature are processed at good pace, however there is still a significant delay in signature.

We'll keep informed regarding this delay.
Posted Jan 07, 2022 - 12:34 CET
Identified
Some clients may experience a delay in signing documents. Our engineers are working to resolve this as fast as possible.

We will update you again shortly here.

If you have urgent questions, please contact our support team by sending an email to support@yousign.com.
Posted Jan 07, 2022 - 11:45 CET
This incident affected: Yousign V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Yousign V3 (APP V3 - https://yousign.app).