Delayed or failed email delivery to Microsoft sender addresses

Incident Report for Yousign

Resolved

Resolved. The backlog is fully delivered: every email held up during the incident has now been sent, and delivery to Microsoft business mailboxes has been back to normal since Microsoft closed its incident.

What happened: from around 11:30 CEST, a global Microsoft incident on inbound mail stopped our notifications from reaching business mailboxes hosted by Microsoft 365 and Exchange Online. Personal addresses such as outlook.com, hotmail.com and live.com were never affected, and no other email provider was involved. Our systems kept sending normally throughout, and the messages were queued by our provider rather than lost.

Once Microsoft restored service, that queue was flushed over the following hours, which is why some notifications arrived late this afternoon and this evening.

The cause and the fix were both on Microsoft's side. What we can improve is how quickly we detect a blockage at a single provider and tell you about it, and we are working on that.

Thank you for your patience, and sorry for the disruption this caused to your day.
Posted Sep 04, 2026 - 23:06 CEST

Monitoring

Microsoft has resolved its incident. Emails to Microsoft business mailboxes are being accepted again, so new notifications go through normally.

The emails held up during the incident are still being sent out by our provider, which reports around 40% of them left to deliver. Until that backlog is cleared, recipients may still receive notifications with a delay. Nothing is lost, and you do not need to send anything again.

How fast that backlog drains depends on our provider and on the rate Microsoft accepts, and is not something we control any more than the incident itself was.

Next update once the backlog is fully delivered.
Posted Sep 04, 2026 - 17:14 CEST

Identified

Update:

This incident is on Microsoft's side, not ours. Our providers have confirmed a global Microsoft incident on inbound mail, which Microsoft has not published on its own status page. Our emails leave our systems and are accepted by our sending providers as usual, then stop at Microsoft.

Since this morning, none of our email notifications reach business mailboxes hosted by Microsoft (Microsoft 365 and Exchange Online). Personal addresses such as outlook.com, hotmail.com and live.com are not affected, and neither is any other provider.

Nothing we can change on our side will deliver these emails, so we cannot fix this incident or commit to a resolution time. We are tracking the fix with our providers, who are in direct contact with Microsoft.

We will tell you whether the emails held since this morning are delivered on recovery or need to be sent again. Next update within the hour.
Posted Sep 04, 2026 - 14:43 CEST

Investigating

Some emails sent to Microsoft-hosted addresses (Outlook, Hotmail, Live and Microsoft 365) are arriving late or not at all. We were alerted by customers at 11:30 CEST, and the number of affected messages rose again after midday.

Our own delivery tracking shows that every email is still being accepted by our sending providers, so the problem appears to occur after that hand-off. We are investigating with them to confirm the cause.

Emails to all other providers are unaffected.

No action is required on your side. We will post a new update as soon as we know more, and we are sorry for the disruption this is causing.
Posted Sep 04, 2026 - 14:30 CEST
This incident affected: Youtrust Notification Providers.