V3 - Delay on qualified eSignatures (QES)

Incident Report for Yousign

Resolved

A fix has been implemented. Pending signatures have been processed.

We sincerely apologize for the inconvenience. For any questions or assistance, contact us at support@yousign.com.
Posted Oct 03, 2025 - 10:12 CEST

Investigating

We're currently experiencing delays in the processing of some QES eSignature requests.

Signatures are still being properly handled. Wallet creation and signature flow are functionals but signed documents cannot be retrieved yet.

All other levels of signature are not affected.

We sincerely apologize for the inconvenience. Our teams are fully mobilized to identify the root cause and implement a solution as quickly as possible.
Posted Oct 03, 2025 - 09:19 CEST
This incident affected: Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).