V3 - Delay on Qualified eSignatures (QES)

Incident Report for Yousign

Update

We are continuing to monitor for any further issues.
Posted Jul 24, 2026 - 14:03 CEST

Monitoring

We're currently experiencing delays on Qualified eSignature (QES).

These delays originate from one of our identity verification providers, which is currently experiencing elevated response times. As a result, identity verification and QES signature completion may take longer than usual.

All other levels of signature (SES, AES) are not affected.

We sincerely apologize for the inconvenience. Our teams are fully mobilized to monitor the situation and restore normal service as quickly as possible. We will provide updates here as soon as possible.
Posted Jul 24, 2026 - 13:29 CEST
This incident affects: Youtrust V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Youtrust V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).