Resolved – Document Uploads & Downloads Unavailable

Incident Report for Yousign

Resolved

[Resolved] Between 13:11 and 13:23 (CEST), users experienced issues with document manipulation - specifically, uploads and downloads were unavailable from both the Yousign App and API.

Our team identified and resolved the issue at 13:23. All document-related operations are now fully restored and functioning normally.

We apologize for any disruption this may have caused to your workflows. If you are still experiencing issues, please do not hesitate to contact our support team.
Posted Mar 03, 2026 - 01:00 CET