A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 11:55 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 17, 2026 - 11:44 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2026 - 11:32 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2026 - 11:26 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 11:25 CEST
Identified
One of our providers is experiencing an outage.
We apologize for the inconvenience and will provide updates as soon as possible.
Posted Jul 17, 2026 - 11:12 CEST
Investigating
We're currently experiencing delays in the processing of some QES eSignature requests.
Signatures are still being properly handled. Wallet creation and signature flow are functionals but signed documents cannot be retrieved yet.
All other levels of signature are not affected.
We sincerely apologize for the inconvenience. Our teams are fully mobilized to identify the root cause and implement a solution as quickly as possible.
Posted Jul 17, 2026 - 10:46 CEST
This incident affected: Youtrust V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).