The signature processing delays have been fully resolved.
Following the deployment of our fix at 12:50, all pending signatures were progressively processed and the backlog was fully cleared by 13:02. All signatures are now being processed normally.
All systems are operating as expected.
We apologize for the inconvenience caused during this incident and thank you for your patience.
Posted Mar 25, 2026 - 13:05 CET
Monitoring
We have deployed a fix to address the signature processing delays.
Signature callbacks backlog is clearing. We are actively monitoring the situation to ensure full recovery.
We will continue to monitor closely and will provide a final update once we confirm the incident is fully resolved.
Thank you for your patience.
Posted Mar 25, 2026 - 12:57 CET
Update
We have identified the root cause of the signature processing delays.
Our engineering team is currently working on implementing a fix. The issue is affecting signature callbacks across all our eSignature products (v2 and v3).
We will notify you as soon as the fix is deployed.
We apologize for the continued inconvenience and appreciate your patience.
Posted Mar 25, 2026 - 12:50 CET
Identified
We are currently experiencing delays in signature processing affecting both our v2 and v3 platforms.
Our team has identified the issue and is actively working on a resolution. Signatures are still being processed but may take longer than usual to complete.
We apologize for any inconvenience this may cause.
Posted Mar 25, 2026 - 12:24 CET
This incident affected: Yousign V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).