V2 & V3 - Access to products v2 & v3 unavailable

Incident Report for Yousign

Postmortem

Impact and Incident Resolution Report

Dear Yousign users,

On December 2nd, 2025, our services experienced two consecutive incidents impacting access to the Yousign platform and temporarily delaying signature processing.
All services were fully restored at 11:53 CET.

Below is a detailed explanation of the events and the actions being taken.

Summary of the two incidents

First Incident (10:53 CET → 11:10 CET)

A hardware malfunction occurred on one of the components of our load balancing layer, responsible for directing incoming traffic to our application services.
The component entered a fault state and shut down, causing a temporary interruption of access to the platform.

It automatically restarted according to its configuration, and all application services were restored at 11:10 CET.

Second Incident (11:32 CET → 11:53 CET)

Immediately after the first recovery, we notified our infrastructure provider.
During the provider's on-site verification of the faulty hardware, a manual reset was triggered on the same component, even though the services had already recovered.

This second reset generated a new interruption between 11:32 CET and 11:45 CET, with signature delays fully resolved at 11:53 CET.

Root Cause

A hardware failure on a load balancing component within our datacenter.

Next Actions

Execution of an exceptional maintenance operation on Monday, December 8th, contributing to the ongoing reinforcement of our traffic management layer and its fault tolerance.

Updated operational guidelines with our infrastructure provider to avoid unnecessary manual resets on recovered systems.

Additional diagnostics and hardware-level actions to ensure long-term reliability.

We sincerely apologize for the impact this incident may have had on your operations.
A full postmortem will be published, including timelines, technical details, and improvements being implemented.

Thank you for your understanding and continued trust in Yousign.

Posted Dec 03, 2025 - 10:13 CET

Resolved

The incident has been resolved and no more delays are observed.

A postmortem will be provided.
Posted Dec 02, 2025 - 11:24 CET

Update

We are continuing to monitor for any further issues.
Posted Dec 02, 2025 - 11:18 CET

Update

Our teams have identified the root cause of the issue, and the fix is being applied. All our Applications are available since 11:06 CET.
Please note that the eSignature will still experience some delay while we process the backlog accumulated during the outage. We will keep you updated as soon as everything is fully back to normal.
Posted Dec 02, 2025 - 11:15 CET

Monitoring

The situation is back to normal since 11:06 CET
Posted Dec 02, 2025 - 11:07 CET

Identified

Our teams have identified the root cause of the issue, and we are now applying the fix.
A return to normal service is expected shortly. We will keep you updated.
Posted Dec 02, 2025 - 11:01 CET

Investigating

All applications (including API) are currently unavailable since 10:53 CET.
Our teams have identified the root cause of the issue, and we are now applying the fix.
A return to normal service is expected shortly. We will keep you updated.
Posted Dec 02, 2025 - 11:01 CET
This incident affected: Yousign V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).