Resolved: As of 14:07 (CET), processing times for signature and eSeal requests have fully returned to normal. All requests are completing as expected. This incident only affected Simple (SES) and Advanced (AES) levels.
Qualified Electronic Signature (QES) and Qualified Electronic Seal (QES/qSeal) were not affected.
This incident is now resolved. All services are operating normally. Thank you for your patience throughout this incident.
Posted Jun 30, 2026 - 14:08 CEST
Identified
Update: Since 14:00 (CET), processing times for signature and eSeal requests have started to recover. Delays are gradually decreasing and requests continue to complete normally. All other services remain unaffected. Our teams continue to monitor the situation closely. We will confirm once processing times have fully returned to normal. Thank you for your patience.
Posted Jun 30, 2026 - 14:06 CEST
Investigating
Since 13:32 (CET), some signature and eSeal requests are experiencing increased processing times. Requests are not lost and continue to complete, though they may take longer than usual to finalize. All other services are operating normally. Our engineering teams have identified the issue and are actively working to reduce these delays. We will provide an update as soon as the situation improves. We apologize for any inconvenience.
Posted Jun 30, 2026 - 13:51 CEST
This incident affected: Yousign V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).