Email Notification Sending Issues

Incident Report for Yousign

Resolved

Previously delayed invitations-to-sign and invitations-to-approve emails have been successfully resent between 4:50 PM and 4:55 PM.
We consider the situation resolved and will keep monitoring to ensure continued stability.
We sincerely apologize for the inconvenience and thank you for your understanding.
Posted Aug 29, 2025 - 18:11 CEST

Update

Email delivery has been fully operational again since 9:52 AM this morning.

Approximately 13% of emails were impacted by the earlier blockage. Thanks to the resilience of our systems, the majority of messages were successfully delivered without disruption.

The affected 13% are currently still pending within Yousign's systems, and our teams are actively working to trigger their replay and delivery by the end of the day.

If you suspect that a message hasn't reached one of your recipients, feel free to contact support@yousign.com — our team can provide further details if needed.

We’ll update this communication as soon as we have new information to share.
Posted Aug 29, 2025 - 15:10 CEST

Identified

We have identified an issue with our V2 & V3 APP & APIs that temporarily prevented some email delivery from yesterday at 18:30 CEST to today at 9:52.

Some emails were not sent properly during this period.
Emails sent outside this window are/were correctly delivered.

We are fully committed to resolving this situation as quickly as possible and will keep you informed of any developments.
Posted Aug 29, 2025 - 10:45 CEST
This incident affected: Yousign Notification Providers.