Our provider has stabilised their systems and we are now observing a gradual return to the nominal situation. We are still actively monitoring.
Posted Sep 14, 2026 - 13:31 CEST
Identified
Our identity verification provider has confirmed an issue at their side leading to instabilities. Although some identity verification requests are successful, the majority is either failing (for AES) or stuck in a pending status. We are actively monitoring the situation and communicate directly with our provider to bring the situation back to normal as soon as possible.
Posted Sep 14, 2026 - 12:42 CEST
Investigating
We're actually experiencing a slowdown of processing time for Advanced Electronic Signature identity verification and standalone Identity Verification service. We are actively working with our Identity Verification provider to understand the root cause and restore service as soon as possible.
Posted Sep 14, 2026 - 12:08 CEST
This incident affected: Youtrust V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).