V3 - APP & API - Signatures delay

Incident Report for Yousign

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 16:55 CET

Identified

We experienced a significant slowdown on v3 signatures between 16:30 and 16:55.
Our team has identified the issue and has been working on resolving it.
Thank you for your understanding.
Posted Mar 27, 2025 - 16:30 CET
This incident affected: Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).