As of 18:05 (CEST), this incident is resolved. All pending Advanced (AES) signatures have been processed, and the signature delay has been fully cleared.
Both Advanced (AES) and Qualified (QES) signature flows are operating normally, along with all other operations on the platform.
We apologise for the inconvenience caused and thank you for your patience.
Posted Aug 13, 2026 - 18:05 CEST
Update
As of 17:53 (CEST), the situation is stabilised. Both Advanced (AES) and Qualified (QES) signature flows are functional again, and signers are able to complete their signatures normally.
We are currently processing the remaining signatures that were pending during the incident. This backlog should be fully cleared within the next few minutes.
All other operations on the platform remain unaffected.
We will continue to monitor the situation closely and will confirm full resolution shortly.
Thank you for your patience.
Posted Aug 13, 2026 - 17:57 CEST
Update
Since 17:11 (CEST), we have been observing a degradation of our services affecting Advanced (AES) and Qualified (QES) electronic signatures.
Current impact:
Advanced electronic signature (AES): signers can complete the signing flow, but signature finalisation is delayed. Documents will be finalised once the service is restored.
Qualified electronic signature (QES): the signing flow is currently unavailable, and signers are unable to complete their signature.
All other operations on the platform, including Simple electronic signature (SES), are operating normally.
Our technical teams are actively working on a resolution. An update will be published as soon as more information is available.
Thank you for your patience.
Posted Aug 13, 2026 - 17:28 CEST
Investigating
Since 17:11 (CEST), we have been observing a degradation of our services, which may result in slowness or intermittent errors when using Product v2 and v3.
Our technical teams are engaged and are currently assessing the precise scope and extent of the impact. An update will be published as soon as more information is available.
Thank you for your patience.
Posted Aug 13, 2026 - 17:22 CEST
This incident affected: Youtrust V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Youtrust V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).