V3 - Delay

Incident Report for Yousign

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 13:32 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 30, 2025 - 11:46 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2025 - 11:46 CEST

Identified

Some clients may experience a delay in accessing Yousign V3 (https://yousign.app). Our engineers are working to resolve this as fast as possible.

We will update you again shortly here.

If you have urgent questions, please contact our support team by sending an email to support@yousign.com.
Posted Jun 30, 2025 - 11:37 CEST
This incident affected: Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).