We are continuing to monitor for any further issues.
Posted Mar 20, 2025 - 10:59 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 10:47 CET
Identified
We would like to inform you of a temporary issue regarding the document rendering which can impact the document display during signature creation and signing process. Our teams are working to resolve this behavior. If you have urgent questions, please contact our support team by sending an email to support@yousign.com.
Posted Mar 20, 2025 - 09:25 CET
This incident affected: Yousign V2 (APP V2 - https://webapp.yousign.com) and Yousign V3 (API V3 - https://api.yousign.app).