Degradation

Incident Report for Yousign

Resolved

Our infrastructure provider performed an update on our low level infrastructure that was supposed to be without impact.
The update is now finished and all services are back to normal.
Sorry for the service degradation that may have happened during this time frame.
Posted Jul 15, 2026 - 21:45 CEST

Identified

The issues has been identified. Our team is working on it.
Posted Jul 15, 2026 - 21:34 CEST

Investigating

Some customers may be experiencing an issue with our service. Our engineers are working to identify and resolve this as fast as possible.

We will update you again shortly here.

If you have urgent questions, please contact our support team by sending an email to support@yousign.com.
Posted Jul 15, 2026 - 21:25 CEST
This incident affected: Youtrust V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).