Resolved – Degraded performance on APP/API v2 / v3

Incident Report for Yousign

Resolved

Between 09:56 and 10:06 CET, customers may have experienced increased latency and intermittent slowness on API v2 and v3 endpoints.

The issue has been identified and resolved. All services are now operating normally.

We apologize for the inconvenience and thank you for your patience.
Posted May 25, 2026 - 10:17 CEST
This incident affected: Yousign V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).