Global Service Degradation – Access to Products v2 & v3 Unavailable

Incident Report for Yousign

Postmortem

## Incident Impact and Resolution Report

Dear Yousign Users, On November 27, 2025 between 08:36 and 09:00 CET, we encountered production issues leading to an important degradation of our services.

## Root Cause Analysis

The virtualization service provided by our infrastructure vendor entered a partially unresponsive state, causing a subset of Virtual Machines to stop responding.
Our engineering team quickly reacted to qualify the issue and then restarted and conciliated the impacted services.

## Next Actions

We are actively challenging our infrastructure provider to determine the root cause of this incident and to elaborate a plan to avoid it in the future as this incident take place after an upgrade of the virtualization service.

As of today we have already identified technical points of failure and we will prioritize the remediation accordingly.

We would like to apologize for the impact on your service and assure you that every effort is being made to learn from this event and ensure that it does not happen again.
Thank you for your understanding and thank you for your continued trust in Yousign.

Posted Nov 27, 2025 - 17:07 CET

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 12:03 CET

Monitoring

Since 09:10, all services are fully back to normal, the delay has been recovered.

Our Engineering teams are now analyzing the root cause of the incident. At this stage, the issue appears to be linked to an impact on our provider’s infrastructure. We will conduct a joint analysis with them to confirm and understand the sequence of events.

We remain in active monitoring.
Posted Nov 27, 2025 - 09:13 CET

Update

Since 09:00, both the applications and the API are available again.
We are still processing the different backlogs accumulated during the incident, which may cause some delays.

We will notify you as soon as everything is fully back to normal.
Posted Nov 27, 2025 - 09:06 CET

Investigating

Since 08:36, access to Yousign products v2 and v3 has been degraded, affecting both the applications and the API.
Our teams are actively investigating to identify the root cause and restore normal service as quickly as possible.

We will provide updates as the situation evolves.
Posted Nov 27, 2025 - 08:52 CET
This incident affected: Yousign V2 (API V2 - https://api.yousign.com, APP V2 - https://webapp.yousign.com) and Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).