The issue has been resolved since 10:22 a.m; our teams are investigating the root cause.
Posted Apr 07, 2026 - 11:19 CEST
Monitoring
The incident is now under monitoring; the situation has been stable since 10:22 a.m.
Posted Apr 07, 2026 - 10:35 CEST
Identified
As of 10:22 a.m., the situation has returned to normal. We have increased our system's processing capacity while we identify the cause of the slowdown.
Posted Apr 07, 2026 - 10:28 CEST
Investigating
We are experiencing performance slowdowns on our v3 Application and API since 9:47 AM UTC+2.
Application: Slower navigation and page load times API: Increased response times on API requests and delays in webhook delivery
Signing delays are not affected by this issue. Our team is actively investigating the root cause. We have increased system capacity to help reduce the impact while we work on a resolution. We will provide updates as we learn more.
Posted Apr 07, 2026 - 10:23 CEST
This incident affected: Yousign V3 (APP V3 - https://yousign.app, API V3 - https://api.yousign.app).